« カラムの高さを調節するjQueryのプラグイン | トップページ | canvasを利用してグラフを制作するjQueryのプラグイン »

2011年2月14日 (月)

IEでCanvasを使えるようにするライブラリ「ExplorerCanvas」

Internet ExplorerでもHTML5のCanvasを使えるようにするライブラリ「ExplorerCanvas」をご紹介いたします。

HTML5のCanvasはFirefoxやGoogleChrome、Safari, Operaなどのブラウザでは利用できますが、Internet Explorer8以前では実装されていませんでした。

ExplorerCanvasライブラリを使用すればInternet Explorerでも擬似的にCanvasを利用することが出来るようになります。

explorercanvas
ダウンロードは上記のURLより可能です。
デモもダウンロードされたデータの中に入っていました。

設定例

ヘッダへの記入
<!--[if IE]>
<script type="text/javascript" src="フォルダ名/excanvas.compiled.js"></script>
<![endif]-->

IEのみ適応させたいので下記のタグを利用してIEだけ読み込ませるように設定します。
<!--[if IE]><![endif]-->

以上で設定が終わりました。

次回からはCanvasも利用したjQueryプラグインのご紹介をしていきたいと思います。

|

« カラムの高さを調節するjQueryのプラグイン | トップページ | canvasを利用してグラフを制作するjQueryのプラグイン »

html」カテゴリの記事

コメント

コメントを書く



(ウェブ上には掲載しません)


コメントは記事投稿者が公開するまで表示されません。



トラックバック

この記事のトラックバックURL:
http://app.f.cocolog-nifty.com/t/trackback/1378074/38839298

この記事へのトラックバック一覧です: IEでCanvasを使えるようにするライブラリ「ExplorerCanvas」:

« カラムの高さを調節するjQueryのプラグイン | トップページ | canvasを利用してグラフを制作するjQueryのプラグイン »